Skip to content

← Public intelligence

Maven package

io.jenkins.plugins:code-coverage-api

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8MavenPublished

    RCE vulnerability in Jenkins Code Coverage API Plugin

    CVE-2021-21677 · GHSA-58pr-hprx-7hg6

    Affected
    • Maven io.jenkins.plugins:code-coverage-api <= 1.4.0
    Fixed in
    1.4.1· Vendor fix available
    Issue
    Jenkins Code Coverage API Plugin 1.4.0 and earlier does not apply JEP-200 deserialization protection to Java objects it deserializes from disk. This results in a remote code execution (RCE) vulnerability exploitable by attackers able to control agent processes. Jenkins Code Coverage API Plugin 1.4.1 configures its Java object deserialization to only deserialize safe types.

    Recommended action: Upgrade to 1.4.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.1MavenPublished

    XXE vulnerability in Jenkins Code Coverage API Plugin

    CVE-2020-2172 · GHSA-cmgm-q8hf-p7jc

    Affected
    • Maven io.jenkins.plugins:code-coverage-api < 1.1.5
    Fixed in
    1.1.5· Vendor fix available
    Issue
    Code Coverage API Plugin 1.1.4 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. This allows a user able to control the input files for the \"Publish Coverage Report\" post-build step to have Jenkins parse a crafted file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery. Code Coverage API Plugin 1.1.5 disables external entity resolution for its XML parser.

    Recommended action: Upgrade to 1.1.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4MavenPublished

    Stored XSS vulnerability in Code Coverage API Plugin

    CVE-2020-2106 · GHSA-xg77-xqhq-crpr

    Affected
    • Maven io.jenkins.plugins:code-coverage-api <= 1.1.2
    Fixed in
    1.1.3· Vendor fix available
    Issue
    Code Coverage API Plugin 1.1.2 and earlier does not escape the filename of the coverage report used in its view. This results in a stored cross-site scripting vulnerability that can be exploited by users able to change the job configuration. Code Coverage API Plugin 1.1.3 escapes the filename of the coverage report used in its view.

    Recommended action: Upgrade to 1.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →