Skip to content

← Public intelligence

Maven package

io.jenkins.plugins:autonomiq

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    Missing permission check in Jenkins autonomiq Plugin

    CVE-2022-25195 · GHSA-6jv7-28mv-qp9c

    Affected
    • Maven io.jenkins.plugins:autonomiq < 1.16
    Fixed in
    1.16· Vendor fix available
    Issue
    A missing permission check in Jenkins autonomiq Plugin 1.15 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials.

    Recommended action: Upgrade to 1.16 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8MavenPublished

    CSRF vulnerability in Jenkins autonomiq plugin

    CVE-2022-25194 · GHSA-g5wh-fw4m-2v28

    Affected
    • Maven io.jenkins.plugins:autonomiq < 1.16
    Fixed in
    1.16· Vendor fix available
    Issue
    Jenkins autonomiq Plugin 1.15 and earlier does not perform a permission check in an HTTP endpoint. This allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified username and password. Additionally, this HTTP endpoint does not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability.

    Recommended action: Upgrade to 1.16 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →