Medium, CVSS 5.4MavenPublished
Stored XSS vulnerability in Jenkins Artifact Repository Parameter Plugin
CVE-2021-21622 · GHSA-gc87-qwmv-7x9x
- Affected
- Maven io.jenkins.plugins:artifact-repository-parameter <= 1.0.0
- Fixed in
- 1.0.1· Vendor fix available
- Issue
- Jenkins Artifact Repository Parameter Plugin 1.0.0 and earlier does not escape parameter names and descriptions. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission. Jenkins Artifact Repository Parameter Plugin 1.0.1 escapes parameter names and descriptions.
Recommended action: Upgrade to 1.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.