Skip to content

← Public intelligence

Maven package

io.jenkins.plugins:agent-server-parameter

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.0MavenPublished

    Stored Cross-site Scripting vulnerability in Jenkins Agent Server Parameter Plugin

    CVE-2022-25191 · GHSA-53c4-cmhf-gp7w

    Affected
    • Maven io.jenkins.plugins:agent-server-parameter < 1.1
    Fixed in
    1.1· Vendor fix available
    Issue
    Jenkins Agent Server Parameter Plugin 1.0 and earlier does not escape parameter names of agent server parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

    Recommended action: Upgrade to 1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →