High, CVSS 7.5MavenPublished
FusionAuth vulnerable to directory traversal attack
CVE-2022-45921 · GHSA-rmcx-fg5w-x8j9
- Affected
- Maven io.fusionauth:fusionauth-java-client >= 1.37.0, < 1.41.3
- Fixed in
- 1.41.3· Vendor fix available
- Issue
- FusionAuth before 1.41.3 allows a file outside of the application root to be viewed or retrieved using an HTTP request. To be specific, an attacker may be able to view or retrieve any file readable by the user running the FusionAuth process.
Recommended action: Upgrade to 1.41.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.