Skip to content

← Public intelligence

Maven package

edu.stanford.nlp:stanford-parser

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.3MavenPublished

    Code injection in stanford-parser

    CVE-2023-39020 · GHSA-353m-jh2m-72v4

    Affected
    • Maven edu.stanford.nlp:stanford-parser < 4.5.5
    Fixed in
    4.5.5· Vendor fix available
    Issue
    stanford-parser v3.9.2 and below was discovered to contain a code injection vulnerability in the component edu.stanford.nlp.io.getBZip2PipedInputStream. This vulnerability is exploited via passing an unchecked argument.

    Recommended action: Upgrade to 4.5.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →