Skip to content

← Public intelligence

Maven package

edu.stanford.nlp:stanford-corenlp

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Improper Restriction of XML External Entity Reference in Stanford CoreNLP

    CVE-2021-3869 · GHSA-8gf7-w3cp-gfh3

    Affected
    • Maven edu.stanford.nlp:stanford-corenlp <= 4.3.0
    Fixed in
    4.3.1· Vendor fix available
    Issue
    corenlp is vulnerable to Improper Restriction of XML External Entity Reference

    Recommended action: Upgrade to 4.3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    Improper Restriction of XML External Entity Reference in Stanford CoreNLP

    CVE-2021-3878 · GHSA-5h9g-8xcv-qjq9

    Affected
    • Maven edu.stanford.nlp:stanford-corenlp <= 4.3.0
    Fixed in
    4.3.1· Vendor fix available
    Issue
    corenlp is vulnerable to Improper Restriction of XML External Entity Reference

    Recommended action: Upgrade to 4.3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8MavenPublished

    Access Control vulnerability within CoreNLP

    CVE-2021-44550 · GHSA-x2p8-rgfm-qw3v

    Affected
    • Maven edu.stanford.nlp:stanford-corenlp <= 4.3.2
    Fixed in
    4.4.0· Vendor fix available
    Issue
    An Incorrect Access Control vulnerability exists in CoreNLP 4.3.2 via the classifier in NERServlet.java (lines 158 and 159).

    Recommended action: Upgrade to 4.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Critical, CVSS 9.8MavenPublished

    corenlp is vulnerable to Improper Restriction of XML External Entity Reference

    CVE-2022-0239 · GHSA-75vw-3m5v-fprh

    Affected
    • Maven edu.stanford.nlp:stanford-corenlp <= 4.3.2
    Fixed in
    4.4.0· Vendor fix available
    Issue
    corenlp is vulnerable to Improper Restriction of XML External Entity Reference

    Recommended action: Upgrade to 4.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →