High, CVSS 8.7MavenPublished
Apache Commons IO: Possible denial of service attack on untrusted input to XmlStreamReader
CVE-2024-47554 · GHSA-78wr-2p64-hpwj
- Affected
- Maven commons-io:commons-io >= 2.0, < 2.14.0
- Fixed in
- 2.14.0· Vendor fix available
- Issue
- Uncontrolled Resource Consumption vulnerability in Apache Commons IO. The org.apache.commons.io.input.XmlStreamReader class may excessively consume CPU resources when processing maliciously crafted input. This issue affects Apache Commons IO: from 2.0 before 2.14.0. Users are recommended to upgrade to version 2.14.0 or later, which fixes the issue.
Recommended action: Upgrade to 2.14.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.