Medium, CVSS 4.6MavenPublished
Cross-site Scripting Vulnerability in Statement Browser
CVE-2024-26140 · GHSA-7rw2-3hhp-rc46
- Affected
- Maven com.yetanalytics:lrs < 1.2.17
- Fixed in
- 1.2.17· Vendor fix available
- Issue
- Impact A maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser. Patches The problem is patched in version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS. Workarounds No workarounds exist, we recommend upgrading to version 1.2.17 of the library or version 0.7.5 of SQL LRS immediately. References LRS Tag LRS lib on Clojars SQL LRS 0.7.5 Release
Recommended action: Upgrade to 1.2.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.