Skip to content

← Public intelligence

Maven package

com.xuxueli:xxl-job-admin

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 2.9MavenPublished

    xxl-job has a Resource Injection issue

    CVE-2026-7303 · GHSA-gw2x-mfwr-h46p

    Affected
    • Maven com.xuxueli:xxl-job-admin < 3.4.0
    Fixed in
    3.4.0· Vendor fix available
    Issue
    A security flaw has been discovered in Xuxueli xxl-job up to 3.3.2. Impacted is the function logDetailCat of the file xxl-job-admin/src/main/java/com/xxl/job/admin/controller/biz/JobLogController.java of the component Execution Log Handler. The manipulation of the argument logId results in improper control of resource identifiers. The attack may be performed from remote. This attack is characterized by high complexity. The exploitability is considered difficult. The exploit has been released to the public and may be used for attacks. Upgrading to version 3.4.0 is recommended to address this issue. The patch is identified as d24e4ccd6073cc75305e1d3b9c29bc8db7437e7a. It is suggested to upgrade the affected component.

    Recommended action: Upgrade to 3.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Low, CVSS 2.1MavenPublished

    xxl-job Vulnerable to Resource Injection and Authorization Bypass Through User-Controlled Key

    CVE-2025-9263 · GHSA-6rq7-m52p-8pqg

    Affected
    • Maven com.xuxueli:xxl-job-admin <= 3.1.1
    Fixed in
    3.2.0· Vendor fix available
    Issue
    A vulnerability has been found in Xuxueli xxl-job up to 3.1.1. Affected by this vulnerability is the function getJobsByGroup of the file /src/main/java/com/xxl/job/admin/controller/JobLogController.java. Such manipulation of the argument jobGroup leads to improper control of resource identifiers. The attack may be launched remotely. The exploit has been disclosed to the public and may be used.

    Recommended action: Upgrade to 3.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Low, CVSS 2.1MavenPublished

    xxl-job Jobs Handler remove function allows improper control of resource identifiers via ID parameter

    CVE-2025-9264 · GHSA-gjx6-h8hm-c9rq

    Affected
    • Maven com.xuxueli:xxl-job-admin <= 3.1.1
    Fixed in
    3.2.0· Vendor fix available
    Issue
    A vulnerability was found in Xuxueli xxl-job up to 3.1.1. Affected by this issue is the function remove of the file /src/main/java/com/xxl/job/admin/controller/JobInfoController.java of the component Jobs Handler. Performing manipulation of the argument ID results in improper control of resource identifiers. Remote exploitation of the attack is possible. The exploit has been made public and could be used.

    Recommended action: Upgrade to 3.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Low, CVSS 2.9MavenPublished

    xxl-job has Inadequate Encryption Strength

    CVE-2025-7789 · GHSA-565h-44m8-4c2v

    Affected
    • Maven com.xuxueli:xxl-job-admin <= 3.1.1
    Fixed in
    3.2.0· Vendor fix available
    Issue
    A vulnerability was found in Xuxueli xxl-job up to 3.1.1 and classified as problematic. Affected by this issue is the function makeToken of the file src/main/java/com/xxl/job/admin/controller/IndexController.java of the component Token Generation. The manipulation leads to password hash with insufficient computational effort. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used.

    Recommended action: Upgrade to 3.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →