High, CVSS 7.5MavenPublished
Play Framework Inadequate Encryption Strength vulnerability
CVE-2019-17598 · GHSA-442g-gcg6-mhm4
- Affected
- Maven com.typesafe.play:play-ws_2.12 >= 2.5.0, < 2.6.24
- Fixed in
- 2.6.24· Vendor fix available
- Issue
- An issue was discovered in Lightbend Play Framework 2.5.x through 2.6.23. When configured to make requests using an authenticated HTTP proxy, play-ws may sometimes, typically under high load, when connecting to a target host using https, expose the proxy credentials to the target host.
Recommended action: Upgrade to 2.6.24 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.