Skip to content

← Public intelligence

Maven package

com.typesafe.akka:akka-http-core_2.12

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Improper Restriction of Operations within the Bounds of a Memory Buffer in akka-http-core

    CVE-2017-1000118 · GHSA-gfx6-ph4q-q54q

    Affected
    • Maven com.typesafe.akka:akka-http-core_2.12 < 10.0.6
    Fixed in
    10.0.6· Vendor fix available
    Issue
    Akka HTTP versions <= 10.0.5 Illegal Media Range in Accept Header Causes StackOverflowError Leading to Denial of Service

    Recommended action: Upgrade to 10.0.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5MavenPublished

    High severity vulnerability that affects com.typesafe.akka:akka-http-core_2.11 and com.typesafe.akka:akka-http-core_2.12

    CVE-2018-16131 · GHSA-9qgc-p27w-3hjg

    Affected
    • Maven com.typesafe.akka:akka-http-core_2.12 >= 10.1.0, < 10.1.4
    Fixed in
    10.1.4· Vendor fix available
    Issue
    The decodeRequest and decodeRequestWith directives in Lightbend Akka HTTP 10.1.x through 10.1.4 and 10.0.x through 10.0.13 allow remote attackers to cause a denial of service (memory consumption and daemon crash) via a ZIP bomb.

    Recommended action: Upgrade to 10.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →