Skip to content

← Public intelligence

Maven package

com.typesafe.akka:akka-actor

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1MavenPublished

    Akka Java Serialization vulnerability

    CVE-2017-1000034 · GHSA-mm57-9j6q-rxm2

    Affected
    • Maven com.typesafe.akka:akka-actor < 2.4.17
    Fixed in
    2.4.17· Vendor fix available
    Issue
    Akka versions <=2.4.16 and 2.5-M1 are vulnerable to a java deserialization attack in its Remoting component resulting in remote code execution in the context of the ActorSystem.

    Recommended action: Upgrade to 2.4.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →