Skip to content

← Public intelligence

Maven package

com.sun.faces:jsf-api

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3MavenPublished

    Cross-site scripting (XSS) vulnerability in Sun Java Server Faces (JSF)

    CVE-2008-1285 · GHSA-vv6j-5x58-q2c3

    Affected
    • Maven com.sun.faces:jsf-api < 1.2.08
    Fixed in
    1.2.08· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in Sun Java Server Faces (JSF) 1.2 before 1.208 allows remote attackers to inject arbitrary web script or HTML via unknown vectors.

    Recommended action: Upgrade to 1.2.08 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →