Medium, CVSS 5.4MavenPublished
Cross-site Scripting in Jenkins Rebuilder Plugin
CVE-2018-1000415 · GHSA-7m8v-w6f9-q2f9
- Affected
- Maven com.sonyericsson.hudson.plugins.rebuild:rebuild < 1.29
- Fixed in
- 1.29· Vendor fix available
- Issue
- A cross-site scripting vulnerability exists in Jenkins Rebuilder Plugin 1.28 and earlier in that allows users with Job/Configuration permission to insert arbitrary HTML into rebuild forms.
Recommended action: Upgrade to 1.29 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.