Skip to content

← Public intelligence

Maven package

com.shopizer:shopizer

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    Cross site scripting in Shopizer

    CVE-2022-23059 · GHSA-p2j7-6g9h-32xh

    Affected
    • Maven com.shopizer:shopizer >= 2.0.2, < 3.0.0
    Fixed in
    3.0.0· Vendor fix available
    Issue
    A Stored Cross Site Scripting (XSS) vulnerability exists in Shopizer versions v2.0.2 through v2.17.0 via the “Manage Images” tab, which allows an attacker to upload a SVG file containing malicious JavaScript code.

    Recommended action: Upgrade to 3.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.8MavenPublished

    Cross-site scripting in Shopizer

    CVE-2021-33561 · GHSA-rcp4-jm2v-mr3f

    Affected
    • Maven com.shopizer:shopizer < 2.17.0
    Fixed in
    2.17.0· Vendor fix available
    Issue
    A stored cross-site scripting (XSS) vulnerability in Shopizer before 2.17.0 allows remote attackers to inject arbitrary web script or HTML via customername in various forms of store administration. It is saved in the database. The code is executed for any user of store administration when information is fetched from the backend, e.g., in admin/customers/list.html.

    Recommended action: Upgrade to 2.17.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 4.8MavenPublished

    Cross-site scripting in Shopizer

    CVE-2021-33562 · GHSA-378p-hrq3-x4p3

    Affected
    • Maven com.shopizer:shopizer < 2.17.0
    Fixed in
    2.17.0· Vendor fix available
    Issue
    A reflected cross-site scripting (XSS) vulnerability in Shopizer before 2.17.0 allows remote attackers to inject arbitrary web script or HTML via the ref parameter to a page about an arbitrary product, e.g., a product/insert-product-name-here.html/ref= URL.

    Recommended action: Upgrade to 2.17.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →