Critical, CVSS 9.3MavenPublished
Improper JWT Signature Validation in SAP Security Services Library
CVE-2023-50422 · GHSA-59c9-pxq8-9c73
- Affected
- Maven com.sap.cloud.security:spring-security < 2.17.0; >= 3.0.0, < 3.3.0
- Fixed in
- 3.3.02.17.0· Vendor fix available
- Issue
- Impact SAP BTP Security Services Integration Library ([Java] cloud-security-services-integration-library) allows under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attacker can obtain arbitrary permissions within the application. Patches Upgrade to patched version = 2.17.0 or = 3.3.0 We always recommend to upgrade to the latest released version. Workarounds No workarounds References https://www.cve.org/CVERecord?id=CVE-2023-50422
Recommended action: Upgrade to 3.3.0 or 2.17.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.