UnratedMavenPublished
Unsafe Deserialization that can Result in Code Execution
CVE-2020-36282 · GHSA-v525-c3g5-cg9p
- Affected
- Maven com.rabbitmq.jms:rabbitmq-jms >= 2.0, < 2.2.0; >= 1.0, < 1.15.2
- Fixed in
- 2.2.01.15.2· Vendor fix available
- Issue
- JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe deserialization that can result in code execution via crafted StreamMessage data.
Recommended action: Upgrade to 2.2.0 or 1.15.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.