Skip to content

← Public intelligence

Maven package

com.qualys.plugins:qualys-pc

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.7MavenPublished

    Qualys Jenkins Plugin for Policy Compliance Cross-site Scripting vulnerability

    CVE-2023-6148 · GHSA-rwf9-8fqr-p44m

    Affected
    • Maven com.qualys.plugins:qualys-pc < 1.0.6
    Fixed in
    1.0.6· Vendor fix available
    Issue
    Qualys Jenkins Plugin for Policy Compliance prior to version and including 1.0.5 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access and access to configure or edit jobs to utilize the plugin to configure a potential rouge endpoint via which it was possible to control response for certain request which could be injected with XSS payloads leading to XSS while processing the response data.

    Recommended action: Upgrade to 1.0.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.7MavenPublished

    Qualys Jenkins Plugin for Policy Compliance XML External Entity vulnerability

    CVE-2023-6147 · GHSA-8525-52vg-jv6v

    Affected
    • Maven com.qualys.plugins:qualys-pc <= 1.0.5
    Fixed in
    1.0.6· Vendor fix available
    Issue
    Qualys Jenkins Plugin for Policy Compliance prior to version and including 1.0.5 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access to configure or edit jobs to utilize the plugin and configure potential a rouge endpoint via which it was possible to control response for certain request which could be injected with XXE payloads leading to XXE while processing the response data

    Recommended action: Upgrade to 1.0.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →