Critical, CVSS 9.8MavenPublished
OrientDB vulnerable to Improper Privilage Management leading to arbitrary command injection
CVE-2017-11467 · GHSA-xm6r-4466-mr74
- Affected
- Maven com.orientechnologies:orientdb-core < 2.2.23
- Fixed in
- 2.2.23· Vendor fix available
- Issue
- OrientDB through 2.2.22 does not enforce privilege requirements during "where" or "fetchplan" or "order by" use, which allows remote attackers to execute arbitrary OS commands via a crafted request.
Recommended action: Upgrade to 2.2.23 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.