High, CVSS 8.8MavenPublished
RCE vulnerability in Jenkins OpenShift Pipeline Plugin
CVE-2020-2167 · GHSA-264w-xrr7-6qqg
- Affected
- Maven com.openshift.jenkins:openshift-pipeline <= 1.0.56
- Fixed in
- 1.0.57· Vendor fix available
- Issue
- OpenShift Pipeline Plugin 1.0.56 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution (RCE) vulnerability exploitable by users able to provide YAML input files to OpenShift Pipeline Plugin’s build step. OpenShift Pipeline Plugin 1.0.57 configures its YAML parser to only instantiate safe types.
Recommended action: Upgrade to 1.0.57 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.