Skip to content

← Public intelligence

Maven package

com.liferay.workspace:com.liferay.ticket.workspace

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.8MavenPublished

    Liferay Stored Cross-site Scripting vulnerability

    CVE-2025-43802 · GHSA-vg6h-g5mr-9hgv

    Affected
    • Maven com.liferay.workspace:com.liferay.ticket.workspace < 20240122.0632
    Fixed in
    20240122.0632· Vendor fix available
    Issue
    Stored cross-site scripting (XSS) vulnerability in a custom object’s /o/c/<object-name API endpoint in Liferay Portal 7.4.3.51 through 7.4.3.109, and Liferay DXP 2023.Q3.1 through 2023.Q3.4, 7.4 update 51 through update 92, and 7.3 update 33 through update 35 allows remote attackers to inject arbitrary web script or HTML via the externalReferenceCode parameter.

    Recommended action: Upgrade to 20240122.0632 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →