Medium, CVSS 5.4MavenPublished
Liferay Portal and Liferay DXP Vulnerable to XSS via the Commerce Module
CVE-2022-42119 · GHSA-wjfm-qxg2-q679
- Affected
- Maven com.liferay.commerce:com.liferay.commerce.catalog.web < 4.0.8
- Fixed in
- 4.0.8· Vendor fix available
- Issue
- Certain Liferay products are vulnerable to Cross Site Scripting (XSS) via the Commerce module. This affects the Commerce module before 4.0.8 from Liferay Portal (7.3.5 through 7.4.2) and Liferay DXP 7.3 before update 8.
Recommended action: Upgrade to 4.0.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.