Critical, CVSS 9.0MavenPublished
Liferay Portal and Liferay DXP Vulnerable to XSS in the Wiki Widget
CVE-2023-42628 · GHSA-hv45-r2f5-fmhj
- Affected
- Maven com.liferay:com.liferay.wiki.web < 7.0.95
- Fixed in
- 7.0.95· Partial vendor fix
- Issue
- Stored cross-site scripting (XSS) vulnerability in the Wiki widget in Liferay Wiki Web before 7.0.95 from Liferay Portal (7.1.0 through 7.4.3.87), and Liferay DXP 7.0 fix pack 83 through 102, 7.1 fix pack 28 and earlier, 7.2 fix pack 20 and earlier, 7.3 update 33 and earlier, and 7.4 before update 88 allows remote attackers to inject arbitrary web script or HTML into a parent wiki page via a crafted payload injected into a wiki page's ‘Content’ text field.
Recommended action: Upgrade to 7.0.95 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.