Skip to content

← Public intelligence

Maven package

com.liferay:com.liferay.users.admin.web

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.1MavenPublished

    Liferay Portal's selection modal is vulnerable to XSS

    CVE-2025-43787 · GHSA-g8fh-pfw3-8rmr

    Affected
    • Maven com.liferay:com.liferay.users.admin.web >= 6.0.6, < 11.0.33
    Fixed in
    11.0.33· Vendor fix available
    Issue
    A stored cross-site scripting vulnerability in the Liferay Portal 7.4.0 through 7.4.3.132, and Liferay DXP 2025.Q3.0, 2025.Q2.0 through 2025.Q2.12, 2025.Q1.0 through 2025.Q1.17, 2024.Q4.0 through 2024.Q4.7, 2024.Q3.0 through 2024.Q3.13, 2024.Q2.0 through 2024.Q2.13 and 2024.Q1.1 through 2024.Q1.20 allows an remote authenticated attacker to inject JavaScript through the organization site names. The malicious payload is stored and executed without proper sanitization or escaping.

    Recommended action: Upgrade to 11.0.33 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.3MavenPublished

    Liferay Portal and Liferay DXP Does Not Obfuscate Password Reminder Answers

    CVE-2021-29038 · GHSA-mwhf-6mjm-6w3h

    Affected
    • Maven com.liferay:com.liferay.users.admin.web < 5.0.33
    Fixed in
    5.0.33· Vendor fix available
    Issue
    In Liferay Impl before 5.18.4, Liferay Users Admin Web before 5.0.33, Liferay Login Web before 5.0.18, and Liferay Commerce Account Web before 3.0.7 from Liferay Portal (7.2.0 through 7.3.5), and older unsupported versions, and Liferay DXP 7.3 before fix pack 1, 7.2 before fix pack 17, and older unsupported versions does not obfuscate password reminder answers on the page, which allows attackers to use man-in-the-middle or shoulder surfing attacks to steal user's password reminder answers.

    Recommended action: Upgrade to 5.0.33 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →