Medium, CVSS 5.4MavenPublished
Liferay Portal and Liferay DXP Vulnerable to XSS in the Site Module
CVE-2022-28978 · GHSA-7m65-hmvg-rxpc
- Affected
- Maven com.liferay:com.liferay.site.memberships.web < 5.0.10
- Fixed in
- 5.0.10· Vendor fix available
- Issue
- Stored cross-site scripting (XSS) vulnerability in the Site module's user membership administration page in Liferay Site Memberships Web before 5.0.10 from Liferay Portal (7.0.1 through 7.4.1), and Liferay DXP 7.0 before fix pack 102, 7.1 before fix pack 26, 7.2 before fix pack 15, and 7.3 before service pack 3 allows remote attackers to inject arbitrary web script or HTML via the a user's name.
Recommended action: Upgrade to 5.0.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.