Low, CVSS 2.0MavenPublished
Liferay Portal Self Cross-site scripting (XSS) vulnerability on the edit Knowledge Base article page
CVE-2025-62255 · GHSA-gccf-r9xp-x8jx
- Affected
- Maven com.liferay:com.liferay.knowledge.base.web < 5.0.109
- Fixed in
- 5.0.109· Vendor fix available
- Issue
- Self Cross-site scripting (XSS) vulnerability on the edit Knowledge Base article page in Liferay Portal 7.4.0 through 7.4.3.101, and older unsupported versions, and Liferay DXP 2023.Q3.1 through 2023.Q3.5, 7.4 GA through update 92, and older unsupported versions allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into an attachment's filename.
Recommended action: Upgrade to 5.0.109 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.