Medium, CVSS 6.1MavenPublished
Liferay Portal and Liferay DXP Cross-site scripting (XSS) vulnerability in the Frontend JS module
CVE-2021-33326 · GHSA-hgjv-7wjr-qwqp
- Affected
- Maven com.liferay:com.liferay.frontend.js.aui.web < 4.0.18
- Fixed in
- 4.0.18· Vendor fix available
- Issue
- Cross-site scripting (XSS) vulnerability in the Frontend JS module before version 4.0.18, in Liferay Portal 7.3.4 and earlier, and Liferay DXP 7.0 before fix pack 96, 7.1 before fix pack 20 and 7.2 before fix pack 9, allows remote attackers to inject arbitrary web script or HTML via the title of a modal window.
Recommended action: Upgrade to 4.0.18 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.