Critical, CVSS 9.0MavenPublished
Liferay Portal and Liferay DXP Vulnerable to Stored XSS in the Manage Vocabulary Page
CVE-2023-42629 · GHSA-g44j-f8wm-6622
- Affected
- Maven com.liferay:com.liferay.asset.categories.admin.web < 5.0.87
- Fixed in
- 5.0.87· Vendor fix available
- Issue
- Stored cross-site scripting (XSS) vulnerability in the manage vocabulary page in the Asset Categories Admin Web module before 5.0.87 from Liferay Portal (7.4.2 through 7.4.3.87), and Liferay DXP 7.4 before update 88 allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into a Vocabulary's 'description' text field.
Recommended action: Upgrade to 5.0.87 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.