Medium, CVSS 6.1MavenPublished
Liferay Portal and Liferay DXP Vulnerable to XSS via the Announcements Module
CVE-2022-42110 · GHSA-2qwm-9mg5-jwq8
- Affected
- Maven com.liferay:com.liferay.announcements.web < 6.0.11
- Fixed in
- 6.0.11· Vendor fix available
- Issue
- A Cross-site scripting (XSS) vulnerability in the Announcements module before 6.0.11 from Liferay Portal (7.1.0 through 7.4.2), and Liferay DXP 7.1 before fix pack 27, 7.2 before fix pack 17, and 7.3 before service pack 3 allows remote attackers to inject arbitrary web script or HTML.
Recommended action: Upgrade to 6.0.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.