Medium, CVSS 5.3MavenPublished
json-path Out-of-bounds Write vulnerability
CVE-2023-51074 · GHSA-pfh2-hfmq-phg5
- Affected
- Maven com.jayway.jsonpath:json-path >= 2.2.0, < 2.9.0
- Fixed in
- 2.9.0· Vendor fix available
- Issue
- json-path v2.8.0 was discovered to contain a stack overflow via the Criteria.parse() method.
Recommended action: Upgrade to 2.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.