Medium, CVSS 6.5MavenPublished
Navigate endpoint is vulnerable to regex injection that may lead to Denial of Service.
CVE-2021-29506 · GHSA-hf44-3mx6-vhhw
- Affected
- Maven com.graphhopper:graphhopper-nav < 2.4
- Fixed in
- 2.4· Vendor fix available
- Issue
- Impact The regex injection that may lead to Denial of Service. Patches Will be patched in 2.4 and 3.0 Workarounds Versions lower than 2.x are only affected if the navigation module is added References See this pull request for the fix: https://github.com/graphhopper/graphhopper/pull/2304 If you have any questions or comments about this advisory please send us an Email or create a topic here.
Recommended action: Upgrade to 2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.