Skip to content

← Public intelligence

Maven package

com.googlecode.plist:dd-plist

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.8MavenPublished

    dd-plist XML External Entitly vulnerability

    CVE-2016-15026 · GHSA-4jx2-hvqw-93j9

    Affected
    • Maven com.googlecode.plist:dd-plist < 1.18
    Fixed in
    1.18· Vendor fix available
    Issue
    A vulnerability was found in 3breadt dd-plist 1.17 and classified as problematic. Affected by this issue is some unknown functionality. The manipulation leads to xml external entity reference. An attack has to be approached locally. Upgrading to version 1.18 is able to address this issue. The name of the patch is 8c954e8d9f6f6863729e50105a8abf3f87fff74c. It is recommended to upgrade the affected component. VDB-221486 is the identifier assigned to this vulnerability.

    Recommended action: Upgrade to 1.18 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →