UnratedMavenPublished
Information leak in Gerrit
CVE-2020-8920 · GHSA-g5q2-cxgq-h2rw
- Affected
- Maven com.google.gerrit:gerrit-plugin-api < 2.14.22; >= 2.15.0, < 2.15.21; >= 2.16.0, < 2.16.25; >= 3.0.0, < 3.0.15; >= 3.1.0, < 3.1.10; >= 3.2.0, < 3.2.5
- Fixed in
- 2.16.253.0.153.2.53.1.102.14.222.15.21· Vendor fix available
- Issue
- An information leak vulnerability exists in Gerrit versions prior to 2.14.22, 2.15.21, 2.16.25, 3.0.15, 3.1.10, 3.2.5 where an overoptimization with the FilteredRepository wrapper skips the verification of access on All-Users repositories, allowing an attacker to get read access to all users' personal information associated with their accounts.
Recommended action: Upgrade to 3.2.5, 3.1.10, 3.0.15 or 3 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.