High, CVSS 7.3MavenPublished
Databricks JDBC Driver Command Injection vulnerability
CVE-2024-49194 · GHSA-jxw2-jvxf-5vrp
- Affected
- Maven com.databricks:databricks-jdbc >= 2.0, < 2.6.40
- Fixed in
- 2.6.40· Vendor fix available
- Issue
- Databricks JDBC Driver 2.x before 2.6.40 could potentially allow remote code execution (RCE) by triggering a JNDI injection via a JDBC URL parameter. The vulnerability is rooted in the improper handling of the krbJAASFile parameter. An attacker could potentially exploit this vulnerability to achieve Remote Code Execution in the context of the driver by tricking a victim into using a crafted connection URL that uses the property krbJAASFile.
Recommended action: Upgrade to 2.6.40 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.