Skip to content

← Public intelligence

Maven package

com.cronutils:cron-utils

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 10.0MavenPublished

    Critical vulnerability found in cron-utils

    CVE-2021-41269 · GHSA-p9m8-27x8-rg87

    Affected
    • Maven com.cronutils:cron-utils < 9.1.6
    Fixed in
    9.1.6· Vendor fix available
    Issue
    Impact A Template Injection was identified in cron-utils enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Versions up to 9.1.2 are susceptible to this vulnerability. Please note, that only projects using the @Cron annotation to validate untrusted Cron expressions are affected. Patches The issue was patched and a new version was released. Please upgrade to version 9.1.6. Workarounds There are no known workarounds up to this moment. References A description of the issue is provided in issue 461 For more information If you have any questions or comments about this advisory: Open an issue in the cron-utils Github repository

    Recommended action: Upgrade to 9.1.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.9MavenPublished

    Template injection in cron-utils

    CVE-2020-26238 · GHSA-pfj3-56hm-jwq5

    Affected
    • Maven com.cronutils:cron-utils < 9.1.3
    Fixed in
    9.1.3· Vendor fix available
    Issue
    Impact A Template Injection was identified in cron-utils enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Versions up to 9.1.2 are susceptible to this vulnerability. Please note, that only projects using the @Cron annotation to validate untrusted Cron expressions are affected. Patches The issue was patched and a new version released. Please upgrade to version 9.1.3. Workarounds There are no known workarounds up to this moment. References A description of the issue is provided in issue 461 For more information If you have any questions or comments about this advisory: Open an issue in cron-utils Github repository

    Recommended action: Upgrade to 9.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →