High, CVSS 8.0MavenPublished
Stored XSS vulnerability in Jenkins Yet Another Build Visualizer Plugin
CVE-2020-2236 · GHSA-3mwj-7vmq-w43p
- Affected
- Maven com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer < 1.12
- Fixed in
- 1.12· Vendor fix available
- Issue
- Yet Another Build Visualizer Plugin 1.11 and earlier does not escape tooltip content. This results in a stored cross-site scripting (XSS) vulnerability exploitable by users with Run/Update permission. Yet Another Build Visualizer Plugin 1.12 escapes tooltip content.
Recommended action: Upgrade to 1.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.