High, CVSS 7.8MavenPublished
Jenkins AWS CodePipeline Plugin has Insufficiently Protected Credentials
CVE-2018-1000401 · GHSA-5gwq-4275-q4qc
- Affected
- Maven com.amazonaws:aws-codepipeline < 0.37
- Fixed in
- 0.37· Vendor fix available
- Issue
- Jenkins project Jenkins AWS CodePipeline Plugin version 0.36 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodePipelineSCM.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.37 and later.
Recommended action: Upgrade to 0.37 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.