High, CVSS 7.8MavenPublished
Insufficiently Protected Credentials in Jenkins AWS CodeBuild Plugin
CVE-2018-1000404 · GHSA-mwg7-69hf-vqh3
- Affected
- Maven com.amazonaws:aws-codebuild < 0.27
- Fixed in
- 0.27· Vendor fix available
- Issue
- Jenkins project Jenkins AWS CodeBuild Plugin version 0.26 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSClientFactory.java, CodeBuilder.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.27 and later.
Recommended action: Upgrade to 0.27 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.