Skip to content

← Public intelligence

Maven package

com.amazon.redshift:redshift-jdbc42

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.2MavenPublished

    Amazon Redshift Vulnerable to Remote Code Execution via Unsafe Class Loading

    CVE-2026-8178 · GHSA-wmmv-vvg5-993q

    Affected
    • Maven com.amazon.redshift:redshift-jdbc42 < 2.2.2
    Fixed in
    2.2.2· Vendor fix available
    Issue
    Amazon Redshift JDBC Driver is a Type 4 JDBC driver that provides database connectivity through the standard JDBC application program interfaces (APIs). An issue exists in versions prior to 2.2.2 where the driver could load arbitrary classes when processing certain connection URL parameters, potentially allowing code execution in the application context. Impact When a JDBC connection URL contains certain parameters, the driver processes the parameter values in a way that could trigger the execution of code from classes available on the application's classpath. An actor who can influence the JDBC connection URL could leverage this to execute code in the context of the application's JVM process. Successful exploitation could allow the actor to read sensitive data, modify application state, or disrupt service availability with the privileges of the application process. Impacted versions: Amazon Redshift JDBC Driver < 2.2.2 Patches This issue has been addressed in Amazon Redshift…

    Recommended action: Upgrade to 2.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.6MavenPublished

    Amazon Redshift JDBC Driver vulnerable to SQL Injection

    CVE-2024-12744 · GHSA-8596-2jgr-ppj7

    Affected
    • Maven com.amazon.redshift:redshift-jdbc42 >= 2.1.0.31, <= 2.1.0.31
    Fixed in
    2.1.0.32· Vendor fix available
    Issue
    A SQL injection in the Amazon Redshift JDBC Driver in v2.1.0.31 allows a user to gain escalated privileges via schema injection in the getSchemas, getTables, or getColumns Metadata APIs. Users should upgrade to the driver version 2.1.0.32 or revert to driver version 2.1.0.30. Impact A SQL injection is possible in the Amazon Redshift JDBC Driver, version 2.1.0.31, when leveraging metadata APIs to retrieve information about database schemas, tables, or columns. Impacted versions: Amazon Redshift JDBC Driver version 2.1.0.31. Patches The issue described above has been addressed in the Amazon Redshift JDBC Driver, version 2.1.0.32. The patch implemented in this version ensures that every metadata command input is sent to the Redshift server as part of a parameterized query, using either QUOTEIDENT(string) or QUOTELITERAL(string). After processing all the inputs into quoted identifiers or literals, the metadata command is composed using these inputs and then executed on the…

    Recommended action: Upgrade to 2.1.0.32 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 10.0MavenPublished

    Amazon JDBC Driver for Redshift SQL Injection via line comment generation

    CVE-2024-32888 · GHSA-x3wm-hffr-chwm

    Affected
    • Maven com.amazon.redshift:redshift-jdbc42 < 2.1.0.28
    Fixed in
    2.1.0.28· Vendor fix available
    Issue
    Impact SQL injection is possible when using the non-default connection property preferQueryMode=simple in combination with application code which has a vulnerable SQL that negates a parameter value. There is no vulnerability in the driver when using the default, extended query mode. Note that preferQueryMode is not a supported parameter in Redshift JDBC driver, and is inherited code from Postgres JDBC driver. Users who do not override default settings to utilize this unsupported query mode are not affected. Patch This issue is patched in driver version 2.1.0.28. Workarounds Do not use the connection property preferQueryMode=simple. (NOTE: If you do not explicitly specify a query mode, then you are using the default of extended query mode and are not affected by this issue.) References Similar to finding in Postgres JDBC: https://github.com/pgjdbc/pgjdbc/security/advisories/GHSA-24rp-q3w6-vc56 If you have any questions or comments about this advisory, we ask that you contact AWS…

    Recommended action: Upgrade to 2.1.0.28 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.1MavenPublished

    com.amazon.redshift:redshift-jdbc42 vulnerable to remote command execution

    CVE-2022-41828 · GHSA-jc69-hjw2-fm86

    Affected
    • Maven com.amazon.redshift:redshift-jdbc42 < 2.1.0.8
    Fixed in
    2.1.0.8· Vendor fix available
    Issue
    Impact A potential remote command execution issue exists within redshift-jdbc42 versions 2.1.0.7 and below. When plugins are used with the driver, it instantiates plugin instances based on Java class names provided via the sslhostnameverifier, socketFactory, sslfactory, and sslpasswordcallback connection properties. In affected versions, the driver does not verify if a plugin class implements the expected interface before instantiatiaton. This can lead to loading of arbitrary Java classes, which a knowledgeable attacker with control over the JDBC URL can use to achieve remote code execution. Patches This issue is patched within redshift-jdbc-42 2.1.0.8 and above. Workarounds We advise customers using plugins to upgrade to redshift-jdbc42 version 2.1.0.8 or above. There are no known workarounds for this issue. For more information If you have any questions or comments about this advisory, please contact AWS Security at aws-security@amazon.com.

    Recommended action: Upgrade to 2.1.0.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →