Critical, CVSS 9.8MavenPublished
Hessian Lite for Apache Dubbo deserialization vulnerability
CVE-2022-39198 · GHSA-5qwq-g2hx-r6f7
- Affected
- Maven com.alibaba:hessian-lite <= 3.2.12
- Fixed in
- 3.2.13· Vendor fix available
- Issue
- A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.17 and prior versions; Apache Dubbo 3.0.x version 3.0.11 and prior versions; Apache Dubbo 3.1.x version 3.1.0 and prior versions.
Recommended action: Upgrade to 3.2.13 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.