Skip to content

← Public intelligence

Maven package

com.alibaba:fastjson

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 10.0MavenPublished

    FASTJSON Includes Functionality from Untrusted Control Sphere

    CVE-2025-70974 · GHSA-jm7w-5684-pvh8

    Affected
    • Maven com.alibaba:fastjson < 1.2.48
    Fixed in
    1.2.48· Vendor fix available
    Issue
    Fastjson before 1.2.48 mishandles autoType because, when an @type key is in a JSON document, and the value of that key is the name of a Java class, there may be calls to certain public methods of that class. Depending on the behavior of those methods, there may be JNDI injection with an attacker-supplied payload located elsewhere in that JSON document. This was exploited in the wild in 2023 through 2025. NOTE: this issue exists because of an incomplete fix for CVE-2017-18349. Also, a later bypass is covered by CVE-2022-25845.

    Recommended action: Upgrade to 1.2.48 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.1MavenPublished

    Unsafe deserialization in com.alibaba:fastjson

    CVE-2022-25845 · GHSA-pv7h-hx5h-mgfj

    Affected
    • Maven com.alibaba:fastjson >= 1.2.25, < 1.2.83
    Fixed in
    1.2.83· Vendor fix available
    Issue
    The package com.alibaba:fastjson before 1.2.83 is vulnerable to Deserialization of Untrusted Data by bypassing the default autoType shutdown restrictions, which is possible under certain conditions. Exploiting this vulnerability allows attacking remote servers. Workaround: If upgrading is not possible, you can enable safeMode.

    Recommended action: Upgrade to 1.2.83 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8MavenPublished

    Improper Input Validation in alilibaba:fastjson

    CVE-2017-18349 · GHSA-xjrr-xv9m-4pw5

    Affected
    • Maven com.alibaba:fastjson <= 1.2.24
    Fixed in
    1.2.31· Vendor fix available
    Issue
    parseObject in Fastjson before 1.2.25, as used in FastjsonEngine in Pippo 1.11.0 and other products, allows remote attackers to execute arbitrary code via a crafted JSON request, as demonstrated by a crafted rmi:// URI in the dataSourceName field of HTTP POST data to the Pippo /json URI, which is mishandled in AjaxApplication.java.

    Recommended action: Upgrade to 1.2.31 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →