Skip to content

← Public intelligence

Maven package

com.adobe.cq:core.wcm.components.core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    AEM WCM Core Components CVG Image vulnerable to Reflected Cross-site Scripting

    CVE-2022-35697 · GHSA-qcgc-6q86-7x2p

    Affected
    • Maven com.adobe.cq:core.wcm.components.core < 2.20.8
    Fixed in
    2.20.8· Vendor fix available
    Issue
    Core Components version 2.20.6 (and earlier) suffer from a reflected cross-site scripting (XSS) vulnerability in AdaptiveImageServlet via SVG images. An attacker with author access can upload a special crafted SVG image (including a malicious Javascript) and obtain a link that, when loaded by another authenticated users, will execute the malicious script and gain access to other user's session. The issue has been resolved in 2.20.8. There are currently no known workarounds.

    Recommended action: Upgrade to 2.20.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →