High, CVSS 7.0MavenPublished
APM Java Agent Local Privilege Escalation issue
CVE-2021-37942 · GHSA-5xqm-hc45-f2g2
- Affected
- Maven co.elastic.apm:elastic-apm-agent >= 1.18.0, < 1.27.1
- Fixed in
- 1.27.1· Vendor fix available
- Issue
- A local privilege escalation issue was found with the APM Java agent, where a user on the system could attach a malicious plugin to an application running the APM Java agent. By using this vulnerability, an attacker could execute code at a potentially higher level of permissions than their user typically has access to.
Recommended action: Upgrade to 1.27.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.