Skip to content

← Public intelligence

Maven package

br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Reflected XSS vulnerability in Jenkins AWSEB Deployment Plugin

    CVE-2020-2174 · GHSA-f82v-pg74-6686

    Affected
    • Maven br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin <= 0.3.19
    Fixed in
    0.3.20· Vendor fix available
    Issue
    AWSEB Deployment Plugin 0.3.19 and earlier does not escape various values printed as part of form validation output. This results in a reflected cross-site scripting (XSS) vulnerability. AWSEB Deployment Plugin 0.3.20 escapes the values printed as part of the affected form validation endpoints.

    Recommended action: Upgrade to 0.3.20 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →