Skip to content

← Public intelligence

Go package

go.etcd.io/etcd/client/pkg/v3

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7GoAmendedPublished

    etcd: tlsListener.acceptLoop spawns unbounded handshake goroutines with no deadline

    CVE-2026-73500 · GHSA-6vch-q96h-7gc3

    Affected
    • Go go.etcd.io/etcd/client/pkg/v3 < 3.5.33; >= 3.6.0, < 3.6.14; >= 3.7.0-alpha.0, < 3.7.1
    Fixed in
    3.5.333.6.143.7.1· Vendor fix available
    Issue
    Impact What kind of vulnerability is it? Who is impacted? A network attacker who can reach an etcd TLS listener can open many TCP connections and never send a ClientHello. Each connection spawns a goroutine in the etcd server process that blocks indefinitely inside tls.Conn.Handshake(), and each is tracked in the pending map. Unbounded goroutine and map growth exhausts memory in the etcd process, causing loss of availability for the etcd cluster (and, when etcd backs Kubernetes, the control plane). Patches Has the problem been patched? What versions should users upgrade to? This vulnerability is patched in the following versions: - etcd 3.7.1 - etcd 3.6.14 - etcd 3.5.33 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? If upgrading is not immediately possible, then restrict network access. Limit which hosts can reach etcd's client (gRPC) port via firewall rules or network policy, reducing who can attempt exploitation. Reporter VMware By…

    Recommended action: Upgrade to 3.7.1, 3.6.14 or 3.5.33 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratedGoPublished

    Etcd pkg Insecure ciphers are allowed by default

    GHSA-5x4g-q5rc-36jp

    Affected
    • Go go.etcd.io/etcd/client/pkg/v3 >= 3.4.0-rc.0, <= 3.4.9; < 3.3.23
    Fixed in
    3.3.233.4.10· Vendor fix available
    Issue
    Vulnerability type Cryptography Detail The TLS ciphers list supported by etcd contains insecure cipher suites. Users can configure the desired ciphers using the “--cipher-suites” flag, and a default list of secure cipher suites is used if empty. Workarounds By default, no action is required. If users want to specify cipher suites using the '--cipher-suites' flag, they should try not to specify insecure cipher suites. Please refer to the security documentation. References Find out more on this vulnerability in the security audit report For more information If you have any questions or comments about this advisory: Contact the etcd security committee

    Recommended action: Upgrade to 3.4.10 or 3.3.23 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →