Skip to content

← Public intelligence

Go package

github.com/zinclabs/zinc

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4GoPublished

    Zinc Cross-site Scripting vulnerability

    CVE-2022-32171 · GHSA-4fgv-8448-gf82

    Affected
    • Go github.com/zinclabs/zinc >= 0.1.9, < 0.3.2
    Fixed in
    0.3.2· Vendor fix available
    Issue
    In Zinc, versions v0.1.9 through v0.3.1 are vulnerable to Stored Cross-Site Scripting when using the delete user functionality. When an authenticated user deletes a user having a XSS payload in the user id field, the javascript payload will be executed and allow an attacker to access the user’s credentials.

    Recommended action: Upgrade to 0.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4GoPublished

    Zinc Cross-site Scripting vulnerability

    CVE-2022-32172 · GHSA-7j6x-42mm-p7jm

    Affected
    • Go github.com/zinclabs/zinc >= 0.1.9, < 0.3.2
    Fixed in
    0.3.2· Vendor fix available
    Issue
    In Zinc, versions v0.1.9 through v0.3.1 are vulnerable to Stored Cross-Site Scripting when using the delete template functionality. When an authenticated user deletes a template with a XSS payload in the name field, the Javascript payload will be executed and allow an attacker to access the user’s credentials.

    Recommended action: Upgrade to 0.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →