Skip to content

← Public intelligence

Go package

github.com/vektah/gqlparser/v2

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3GoPublished

    gqlparser denial of service vulnerability via the parserDirectives function

    CVE-2023-49559 · GHSA-2hmf-46v7-v6fx

    Affected
    • Go github.com/vektah/gqlparser/v2 < 2.5.14
    Fixed in
    2.5.14· Vendor fix available
    Issue
    An issue in vektah gqlparser open-source-library v.2.5.10 allows a remote attacker to cause a denial of service via a crafted script to the parserDirectives function.

    Recommended action: Upgrade to 2.5.14 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →