Medium, CVSS 5.3GoPublished
gqlparser denial of service vulnerability via the parserDirectives function
CVE-2023-49559 · GHSA-2hmf-46v7-v6fx
- Affected
- Go github.com/vektah/gqlparser < 2.5.14
- Fixed in
- 2.5.14· Vendor fix available
- Issue
- An issue in vektah gqlparser open-source-library v.2.5.10 allows a remote attacker to cause a denial of service via a crafted script to the parserDirectives function.
Recommended action: Upgrade to 2.5.14 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.