Medium, CVSS 6.5GoPublished
tar-split memory exhaustion
CVE-2017-14992 · GHSA-hqwh-8xv9-42hw
- Affected
- Go github.com/vbatts/tar-split < 0.10.2
- Fixed in
- 0.10.2· Vendor fix available
- Issue
- Lack of content verification in Docker-CE (Also known as Moby) versions 1.12.6-0, 1.10.3, 17.03.0, 17.03.1, 17.03.2, 17.06.0, 17.06.1, 17.06.2, 17.09.0, and earlier allows a remote attacker to cause a Denial of Service via a crafted image layer payload, aka gzip bombing.
Recommended action: Upgrade to 0.10.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.